From: Stefano Sabatini <stefasab@gmail.com> To: FFmpeg development discussions and patches <ffmpeg-devel@ffmpeg.org> Subject: Re: [FFmpeg-devel] [PATCH] lsws/swscale.h: introduce sws_get_gaussian_vec Date: Wed, 6 Sep 2023 00:59:44 +0200 Message-ID: <ZPey4LnGeA+bez2H@mariano> (raw) In-Reply-To: <169391274067.20400.12945788077351942626@lain.khirnov.net> On date Tuesday 2023-09-05 13:19:00 +0200, Anton Khirnov wrote: > Quoting Stefano Sabatini (2023-09-01 20:28:33) > > On date Friday 2023-09-01 17:50:56 +0200, Anton Khirnov wrote: > > > Quoting Stefano Sabatini (2023-08-31 17:06:06) > > > > On date Saturday 2023-08-26 17:15:36 +0200, Anton Khirnov wrote: > > > > > Quoting Stefano Sabatini (2023-08-26 14:23:28) > > > > > > Use in place of sws_getGaussianVec. > > > > > > > > > > > > The new function enable better log handling, and provide better naming > > > > > > for the variance variable, now named standard_deviation to reflect the > > > > > > meaning of the parameter. > > > > > > > > > > > > > > Logging to NULL does not seem like an improvement to me. > > > > > > > > Adding the log_ctx. > > > > > > > > > Renaming a function parameter does not require an API break. > > > > > > > > The main point was improving the naming of the variable, but while at > > > > it I'm also adding the logging context and providing a return code to > > > > specify an error failure, and moving to snake_case convention which is > > > > the one used by the new API additions. > > > > > > As I already said above - function parameter names in a prototype are > > > purely cosmetic and have no effect on anything besides doxygen. You can > > > change them at will and even remove them entirely without breaking API > > > or ABI. > > > > > > > > The other reasons do not strike me as strong enough to warrant an API > > > break. > > > > I disagree on this: the function is probably only used internally and > > by libavfilter, and the migration is trivial enough so should cause no > > disruption anyway. > > The migration is not trivial for someone who is not familiar with the > code (such as a distro package maintainer), since the new function has a > different signature. I really do not think we should break APIs for > frivolous reasons, which includes cosmetic ones. Following this logic every API change should be considered not trivial for someone not familiar with the code, and therefore should not be committed. Also there is no evidence that external components are using this function. Besides the naming change, there are ergonomic and functional changes making the behavior of the code more correct. (Also probably it would be worth moving the naming of all the remaining functions to snake_case to provide a consistent API - and reduce the cognitive overload on the API user). _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-request@ffmpeg.org with subject "unsubscribe".
next prev parent reply other threads:[~2023-09-05 22:59 UTC|newest] Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top 2023-08-26 12:23 Stefano Sabatini 2023-08-26 15:15 ` Andreas Rheinhardt 2023-08-31 15:32 ` Stefano Sabatini 2023-08-31 16:51 ` Andreas Rheinhardt 2023-08-31 17:16 ` Stefano Sabatini 2023-09-01 16:54 ` Michael Niedermayer 2023-09-01 18:38 ` Stefano Sabatini 2023-09-02 20:07 ` Michael Niedermayer 2023-09-03 0:25 ` Stefano Sabatini 2023-09-03 16:34 ` Michael Niedermayer 2023-08-26 15:15 ` Anton Khirnov 2023-08-31 15:06 ` Stefano Sabatini 2023-09-01 15:50 ` Anton Khirnov 2023-09-01 18:28 ` Stefano Sabatini 2023-09-05 11:19 ` Anton Khirnov 2023-09-05 22:59 ` Stefano Sabatini [this message] 2023-09-06 11:13 ` Anton Khirnov 2023-11-04 21:38 ` Stefano Sabatini
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=ZPey4LnGeA+bez2H@mariano \ --to=stefasab@gmail.com \ --cc=ffmpeg-devel@ffmpeg.org \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
Git Inbox Mirror of the ffmpeg-devel mailing list - see https://ffmpeg.org/mailman/listinfo/ffmpeg-devel This inbox may be cloned and mirrored by anyone: git clone --mirror https://master.gitmailbox.com/ffmpegdev/0 ffmpegdev/git/0.git # If you have public-inbox 1.1+ installed, you may # initialize and index your mirror using the following commands: public-inbox-init -V2 ffmpegdev ffmpegdev/ https://master.gitmailbox.com/ffmpegdev \ ffmpegdev@gitmailbox.com public-inbox-index ffmpegdev Example config snippet for mirrors. AGPL code for this site: git clone https://public-inbox.org/public-inbox.git